Elantra Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I've got an 06 Elantra and for some reason it doesn't crank or start. When I turn key to on position all lights and instrument panel comes on but when I try to start 2 light clicks from toe main and start solenoids then everything turns off and does nothing even with key only being turned to the on position for several seconds. Fuses are good. Main and start relays are good. Battery is good, tapped on the starter and nothing. Suspected the remote wire so put a spade clip on the solenoid, turned key to on position and touched a wire leading to solenoid to the + term on the batt, and no joy. Ordered new starter from Rock Auto ( always hook it up on price & quality ) put new starter in and nothing! I tried removing the control wire from the car and jumping that solenoid and nothing again! I've tested that there is constant 12 V at the lug on starter that remains hot. So there's power that went to both and I went directly to the battery with the control and nothing. I tested the original starter and it turned out to be good even though I haven't bench tested the brand new one because of the headache removing and reinstall, but I assume the new one is good because in having the same condition as the old one. This makes absolutely no sense to me. Everything points to the starter and that's really the only thing in that circuit that is failing! PLEASE HELP as this is my only mode of transportation and I'm a single dad and can't afford to take it to the shop.
 
1 - 1 of 1 Posts
Top