Elantra Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 2012 Hyundai Elantra and lately when I am going around 40 km/hr I will push the gas but my car won't accelerate. I take my foot off the gas for a second and try again and it works. Yesterday my tachometer stopped working as well but when I turned the vehicle off and turned it on again it was working. I had taken it to the mechanics last week and they only found one code showing up and when they reset it, it never came back - basically they couldn't find anything wrong. The code was C1611 control area network. Any help would be appreciated!
 

·
Registered
2018 Hyundai Elantra SE 2.0L 6MT
Joined
·
20 Posts
I have a 2012 Hyundai Elantra and lately when I am going around 40 km/hr I will push the gas but my car won't accelerate. I take my foot off the gas for a second and try again and it works. Yesterday my tachometer stopped working as well but when I turned the vehicle off and turned it on again it was working. I had taken it to the mechanics last week and they only found one code showing up and when they reset it, it never came back - basically they couldn't find anything wrong. The code was C1611 control area network. Any help would be appreciated!
is that the only code?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
None, I was thinking maybe it's some kind of sensor? A friend suggested trying some fuel system cleaner
 

·
Registered
2018 Hyundai Elantra SE 2.0L 6MT
Joined
·
20 Posts
None, I was thinking maybe it's some kind of sensor? A friend suggested trying some fuel system cleaner
You need repairs on possibly your CAN bus wiring or the CAN replaced. Its basically the car's communication system between ECUs
 
1 - 6 of 6 Posts
Top