Elantra Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 2013 Hyundai Elantra that I bought new. It has been a great car! I now have issues with the air conditioner not working. The compressor clutch will not engage so I checked free on and it shows in the red. Of course it will because the compressor is not turning. So that tells me it has Freon. Does anyone have any suggestions or ideas? It is a limited with the climate control. Any help would be greatly appreciated!
 

·
Registered
Joined
·
19 Posts
How did you check freon? Gauges?
The clutch will not engage if it is low so I am confused by your statement. You should still get some kind of readings even if the compressor doesn't spin.

Finally I'd say, check the fuse?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Thank you for your response. I have checked all relays and fuses. When I put the gauge on the AC line the needle pretty much buried in the red. I have put freon in vehicles before and usually when the compressor is not running the gauge is high. Am I right about that? If you got any ideas I really appreciate it.
 

·
Registered
Joined
·
19 Posts
Too high or too low of pressure could keep it from engaging.
I don't know a lot about AC systems - I honestly think you would be better off getting a professional to look at something like this. You may need to have it evacuated/refilled, there may also be something clogging the system if the pressures are pegged.
 
1 - 6 of 6 Posts
Top