Elantra Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I bought the most basic SE with standard transmission i could get. I did the first oil change at 3,500 miles. The light came on around 7,000 miles. I was told it was just the oil light scheduled for 7,000 and I could ignore. However, I just changed the oil again at 10,450 miles and I cannot get the light to turn off.

I do not have any of the fancy menu buttons or an ok button on my steering wheel. I do not have cruise control and I do not have an 'ok' button anywhere.

I tried the only directions I could find to start the car hold reset for 5 seconds, let go hold reset for 1 second. I tried various permutations of this sequence car on and off, engine on and off and the 2 key positions before the engine starts up on and off.

The light is still on.

Any ideas? I will get in touch with dealer but I would like to reset asap and just the chore ticked off my list before I forget about during the week when work becomes all absorbing.

Thanks,
Caroline
 

·
Registered
Joined
·
12 Posts
The car needs to be running. If looking at the steering wheel, there should be a button on the right side, that might say RESET, instead of OK. Use the navigate button to move your menu screen to the wrench icon. Use the Up/Down keys to change to oil service. Once on that screen, press and hold the RESET button. If there is not a button, sometimes they may use the up/down rocker button as the OK/RESET button, by pressing in on it. A picture of your steering wheel, and dash would be of great help. Please also let us know which year your car is.
 
1 - 2 of 2 Posts
Top