Elantra Forum banner
1 - 2 of 2 Posts

· Registered
1 Posts
Discussion Starter · #1 ·
Hi everyone,

Hoping for help to diagnose this horn problem in our 2011 Elantra sedan:
About 6 months ago, the horn stopped working. Replayed the relay and it worked fine -- at first.
About 3 months ago, the horn seemed to work intermittently. Weird.
For about the past month, no horn.

My attempt at diagnosis:
Relay -- We also happen to own a 2013 Elantra GT. I swapped in the relay from the GT into the 2011 sedan, but the horn still didn't work. The 2011 Elantra relay, however, worked fine in the 2013. There's an audible clicking sound from fuse box area when horn button pressed. So, that tells me it's not the relay.
Fuse -- I swapped out the fuse too. No luck.
Horn itself -- I removed the horn and connected it directly to the battery. The horn worked, so it seems fine.
Electrical connection -- the connector was clean and dry and tight. No corrosion or other weirdness that I could see.
Clock spring -- All other steering wheel functions work fine. I spun the steering wheel around and the horn didn't come back to life.

Can I do anything else before taking it in to a mechanic?

My guess is that there's a bad ground or broken wire somewhere preventing the power from getting to the horn. I looked, but didn't see anything obvious.

I searched the forum and didn't find an answer to this. If this has been answered elsewhere, please let me know.

1 - 2 of 2 Posts