2002 Hyundai Elantra GLS down on power. - Hyundai Elantra Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 09-20-2019, 01:09 AM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2002 Hyundai Elantra GLS down on power.

My 2002 Elantra GLS has no power on take off and boggs while going up hill but it seems as if the power returns at around 3000rpm, also I have yet to get any better than 21 mpg even on highway. I recently did plugs and wires which fixed a misfire problem I had, and it has a cam sensor code that I am unsure has any correlation with the other problems because I replaced both cam and crank sensors to no avail as the code is still there.
Alex Wirtanen is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-20-2019, 08:57 PM
Member
 
sooperkleen19's Avatar
 
Join Date: Jul 2019
Location: Copperas Cove, Texas
Posts: 41
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Garage
Hi Alex...what's the code? I can research it for you at work, give you some possible fixes. What type of plugs did you install? Hyundai's are real sketchy with plugs like champion and autolite....recommend NGK all day.

Question: When you start the car in the morning when the engine is cold do you hear any abnormal noises at start up? Does your tachometer work at start up immediately? Also, aftermarket parts such as cam and crank sensors are also sketchy with Hyundai....maybe not so much on the older models like yours.

How is your maintenance history? How frequent are your oil changes? It would be worth sticking a scope under the oil cap to see if your engine is sludged up. Aso worth pulling your oil control valves and check for sludge or metal particles. Good luck.

2019 Hyundai Elantra 2.0
1994 Nissan Sentra SE-R SR20DE

"Train your people for success when they leave, treat them so they won't want to"
sooperkleen19 is offline  
post #3 of 3 (permalink) Old 09-24-2019, 08:57 PM
Junior Member
 
Join Date: Aug 2019
Location: Cajun Country Louisiana
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Alex, I have a 2005 Elantra GLS sedan. Sooperkleen19 has it correct about aftermarket parts on the Hyundai. Starting about the 2002 models, the computer programming looked for specific parameters of the sensors, and usually only the OEM parts worked correctly. I've spent money buying aftermarket parts only to find that the OEM computer doesn't like them. Stick with OEM whenever you can.

The only other solution is to replace the computer with an aftermarket one that is programmable, but its really not worth the cost nor time to reprogram it.

You should have sent us the code you were getting. It would be easier for anyone to try to figure what the problem was.
jdmeaux2002 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Elantra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome