2nd replacement of mcpherson strut bearing - Hyundai Elantra Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 01-08-2015, 09:20 PM Thread Starter
Junior Member
 
Join Date: Jan 2015
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2nd replacement of mcpherson strut bearing

Passenger side strut bearing(at top of McPherson Strut assembly) defective AGAIN. 2nd one in 6 months on a 2012 Elantra Sedan with 29 K on the clock. Car started squeaking when turned hard right(while sitting still) or when going up a slight incline into a parking lot(also turning right while entering the parking lot). McPherson Strut system has a bearing at the top which attaches to the underside of the fender well. This bearing allows the entire strut assembly to rotate as you steer the car unlike a conventional coil over shock system which is NOT attached to the steering knuckle meaning it is fixed(doesn't turn as wheels turn). Has anyone heard of this strut bearing problem on the Elantra? This is the 2nd time in 6 months having to replace the same part(under warranty at the dealership). It is highly unusual to replace this strut bearing on such a low mileage car. Twice in 6 months is unheard of.

Last edited by eallanboggs; 01-08-2015 at 09:23 PM.
eallanboggs is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Elantra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome