Momentary loss of accleration - Hyundai Elantra Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 12-06-2014, 12:06 AM Thread Starter
Junior Member
 
Join Date: Dec 2014
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Momentary loss of accleration

Have 2002 elantra sedan. has 105,000 miles on it. Had to replace transmission two weeks ago. Check engine light on . Told its oxygen sensor. When driving engine suddenly has no pick up and feels like it is going to stall. This happens within the first couple of minutes of driving. That last for about thirty seconds and then engine starts to pick up again and I can accelerate.
While it is happening even If I press the gas pedal engine feels like it is just flirting with no acceleration. Put bottle of cataclean in gas tank. Was told that make clean catalytic and clear sensors.
Any ideas on why I would get that loss of power and no acceleration. Only last for about thirty seconds but nerve racking when trying to get on highway or cross a heavy traffic street.
Woodchip is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Elantra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome