Horn and Lock Actuator Issues - Hyundai Elantra Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 07-29-2019, 10:24 PM Thread Starter
Junior Member
 
Join Date: Jul 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Question Horn and Lock Actuator Issues

Hi:
I have a 2010 Hyundai Elantra sedan, and I've had some recent issues that I was wondering if anyone else has experienced. It started with what appears to a be a failing lock actuator in the rear door on the driver's side. It would periodically not lock with the FOB and the horn wouldn't beep in those instances (I've since ruled out the FOB as the issue). Then the horn seemed to die about two months ago. I replaced the horn with a Wolo generic one from Advance Auto, which worked fine but then the new one died two months later. So I then replaced the horn relay along with all the horn fuses, but it still won't work.

I'm guessing there is some sort of correlation with the lock actuator failing, but does anyone know if a failed lock actuator can somehow short out the horn? I've never heard anything like that happening before, but I'm hoping to figure out the root cause so I don't have to take the front bumper off again to get to the horn only to have it fail again in few months.
Any ideas are greatly appreciated.
Thanks
Peter
PJRVA is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Elantra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome