Hyundai elantra 2011 vibrates at all speeds and idle, Malfunction indicator light on - Hyundai Elantra Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 03-15-2017, 09:33 PM Thread Starter
Junior Member
 
Join Date: Mar 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hyundai elantra 2011 vibrates at all speeds and idle, Malfunction indicator light on

Hello, I have Hyundai elantra 2011 GLS, 75,000 miles on it. I am first owner and oil changed last week at dealer(Synthetic).
Car was running smooth when I parked on Monday night, Tuesday we had a snow storm.
Today morning car started normal but after driving 15 miles it started to vibrate. It vibrates at all speeds. RPM gauge needle keeps shaking as well... even in idle. Malfunction indicator light turns on steady as soon as vibration starts but it goes away for a while when I lift foot from accelerator and comes back as soon I press paddle little bit.
If I pull over and shut off engine and start it again, Car starts normal. But vibration comes back within 5-6 minutes if I drive normally or after 10-15 minute if I accelerate and brake as gently as possible. If vibration ever starts, it wont stop until I restart engine. Tomorrow I will go to AUTOZONE to diagnose error code. Any possible solutions?
pratik155 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Elantra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome