getting strange noise at idle. - Hyundai Elantra Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 12-16-2014, 09:49 PM Thread Starter
Junior Member
 
Join Date: Dec 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
getting strange noise at idle.

2006 GLS with appx 85K on motor.. car has 164K on speedometer.

When i crank up and just sit at idle there is a squeeking noise like a loose belt.
i have check all the belts and all are tight.

the noise seems to be coming from drive belt end of motor somewhere.

anyone have an idea on this.

ps when the engine speed increased it seem to go away.. i can sit at a light and put in N and the sound sorta goes away.

could this be something with the timing belt or the idler pulley in there.??
carl2591 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Elantra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome