Gauges randomly stopped working? - Hyundai Elantra Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 03-15-2019, 10:35 PM Thread Starter
Junior Member
 
Join Date: Mar 2019
Location: Littleton, Co
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Question Gauges randomly stopped working?

My girlfriend has a 2013 Elantra gls. I have read some other threads but can't seem to find a good answer or solution. Today, after starting the car, noticed that the speedometer, odometer, gas gauge, rpms are all not working. They all light up but nothing works. The only thing that is reading is the Temp Gauge. Check engine light came on and got a P0462 (fuel level A sensor circuit low input). I disconnected the battery, checked fuses, flipped I/P switch on and off. Still nothing. Would a fuel sensor cause the gauges to not work? To me, I am thinking the check engine light came on because the gauges aren't working so the car thinks the fuel sensor isn't working too??? This all happened out of no where, no signs of anything.


Last edited by alipke3; 03-15-2019 at 10:38 PM.
alipke3 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-19-2019, 08:11 PM
Junior Member
 
Join Date: Mar 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Was the temperature extremely cold prior, a day or two, to this event? Was there rain or snow prior to the issue?

I had the same problem and determined that I have a humidity problem (aka - Leak). I sealed a few possibilities and am waiting for the next extreme wet day and / or cold day to cause high humidity in the vehicle. I also had frost on the INSIDE of the windows, prior to the failure. My quick fix.... air it out and it worked a few hours later. (Typical of this problem.) Permanent fix will be to find the cause of the high humidity.

I searched and found others with same symptoms, that led up to the failure that we all had. My car is a 2013 Elantra sedan. Only 36,000 miles.

Let us know!
DocDoug is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Elantra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome