13 Coupe SE - Hyundai Elantra Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 07-19-2015, 08:44 AM Thread Starter
Junior Member
 
rangers484's Avatar
 
Join Date: Jul 2015
Location: Charlottesville, VA
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage
13 Coupe SE

Have had my Coupe now for about 6 mo. Bought it used after seeing it sit at the local KIA dealer for 7 mo. Nice and clean, low mileage 6 spd. I seriously negotiated down the price over 2 mo. The car sat because it was a manual transmission but I enjoy driving manual so it was right up my alley. So far I have installed projector headlights, rear led tail lights, tinted the windows, Compass Nav system and window vent visors (long story on how I acquired them). A few other minor mods as well. Really enjoying this car and it is getting about 35mpg around town and 40 on the highway. I am surprised it gets higher than the stated MPG.

Molon Labe
rangers484 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-20-2015, 04:52 AM
Supporting Vendor
 
carid's Avatar
 
Join Date: Jun 2013
Location: Cranbury, New Jersey
Posts: 149
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Welcome aboard! Glad to hear you are enjoying your SE! Good luck with all your future mods, make sure to show us some pics!

Hyundai Elantra http://www.carid.com/hyundai-elantra-accessories/
Call Toll Free: 800.505.3274 | Facebook | Twitter | YouTube
carid is offline  
post #3 of 5 (permalink) Old 07-31-2015, 07:25 AM
Senior Member
 
Join Date: Aug 2013
Posts: 171
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage
Another coupe owner! Ya!!! Congrats on the new ride!
Vsx1 is offline  
 
post #4 of 5 (permalink) Old 08-01-2015, 09:35 PM Thread Starter
Junior Member
 
rangers484's Avatar
 
Join Date: Jul 2015
Location: Charlottesville, VA
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage
So I added pics to my garage but the set up page still says I need to set up my garage. What am I doing wrong?

Molon Labe
rangers484 is offline  
post #5 of 5 (permalink) Old 08-02-2015, 11:01 AM
Senior Member
 
Join Date: Aug 2013
Posts: 171
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage
Nothing appears wrong, I saw 4 or so pics, red coupe. Very nice.
Vsx1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Elantra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome